PSA Service Degradation
Resolved
Aug 11, 2026 at 11:28am UTC
Azure Service Bus Connectivity Issues
We’re pleased to confirm that the connectivity issues affecting the PSA service have been resolved.
Current Status: Resolved
Impact: Intermittent connectivity drops, message timeouts, and related delays have returned to normal.
Our engineering team has continued to monitor the service and has confirmed that the system is operating normally.
Affected services
Updated
Aug 11, 2026 at 10:45am UTC
Update: Azure Service Bus Identified as Cause of Connection Issues
Following up on our previous notice, our engineering team has isolated the root cause of the intermittent connection drops to our Azure Service Bus infrastructure.
Current Status: Active Mitigation & Troubleshooting
Impact: Continued connectivity drops and message timeouts due to the underlying Azure service performance.
Next Steps: Our team is currently in communication with the Microsoft team
Affected services
Created
Aug 11, 2026 at 10:06am UTC
We are currently investigating an issue affecting the PSA service. Customers may experience degraded performance, including delays when loading and updating tickets, intermittent failures when updating ticket status, issues with inbound email ingestion, and delays or failures when sending outbound ticket comments.
Our team is actively investigating the issue and working to restore normal service. We will provide further updates as more information becomes available.
Affected services