Back to overview
Resolved

In-app notifications delayed or not appearing

Aug 21, 2026 at 1:30am UTC
Affected services
PSA
PSA

Resolved
Aug 21, 2026 at 4:33am UTC

This incident is now resolved. In-app notification delivery has been stable in both regions since and all services are operating normally.

Updated
Aug 21, 2026 at 4:15am UTC

We've applied a fix and in-app notification delivery has returned to normal levels in both the US and Australian regions. We're monitoring closely to confirm the issue is fully resolved.

If you're still not seeing new notifications in the web app, a browser refresh should resolve this. Please contact support if the problem persists.

Updated
Aug 21, 2026 at 3:38am UTC

Our team has identified the underlying cause of this issue and is working on a fix. This is a platform-side issue and does not require any action from customers.

Ticketing, monitoring, alerting and automations remain unaffected, and no alert or event data has been lost — the impact is limited to in-app notification delivery.

Created
Aug 21, 2026 at 1:30am UTC

We're investigating an issue affecting in-app notifications in both our US and Australian regions. Some users may not be receiving notifications in the web app, or may be receiving them with a delay.

All other parts of the platform — including ticketing, device monitoring, alerting and automations — are operating normally.

Our engineering team is actively investigating.